DocProject 2008 Installer fails

Topics: Bugs, General Questions
Aug 15, 2007 at 10:52 AM
Hi Dave,

Great work on getting 2008 support! However, the DocProject 2008 installer appears to be failing for me. When I start it I get the error:

"This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to vierty that this is a valid windows installer package"

Not sure if the download on the site is corrupted or not. The 1.70RC installed fine.

Thanks

Ben
Coordinator
Aug 15, 2007 at 11:09 AM
Hi Ben,

That happened to me also a few times. I really don't know why. When it did I would just try it again and it worked :)

Please let me know if trying again helps.

It may have something to do with the fact that I built the IExpress package on Microsoft's Windows Server 2003 VM for Visual Studio 2008 Beta 2. I don't know. As you stated the 1.7.0 installer works fine every time, and that was packaged on Vista :)

Thanks,
Dave
Aug 23, 2007 at 9:40 PM
Hi Guys,

I've got the exact same issue on Vista 32bit. I've tryed running the installer as administrator, from several directories, checked permissions etc and it still does not seem to want to run (same error as Ben). A colleague running on XP can run the installer without issue.

The 1.70RC also installed fine.

Let me know if you'd like anything tested.

Greg
Coordinator
Aug 23, 2007 at 9:50 PM
Hi Greg,

I've already built another version of the installer for DocProject 2008 (on my Vista 32bit dev machine) that should work better. I sent it to Ben to try it out, but I haven't heard back from him yet. If you want to try a copy of the new installer I'd appreciate any feedback you can give me (and if it's positive I'll probably just replace the currently deployed version with the new one).

Send me your e-mail address and I'll get it to you.

Thanks,
Dave
Coordinator
Aug 24, 2007 at 10:14 AM
Edited Aug 24, 2007 at 10:14 AM

Update for all 2008 users

The new version of the installer that I built on Vista seems to produce the same error according to Greg. Here's a possible work-around for now if you're experiencing the same problem with the current release:

  1. Create a new text file in the same directory as the DocProject08-Beta.exe installer and name it extract.bat
  2. Add the following line and save the changes:
DocProject08-Beta.exe /C /T:"%~dp0Contents"
  1. Double-click the new batch file to run it. A new folder named Contents with the extracted files should be appear in the same directory.
  2. Open the Contents folder.
  3. Try running Setup.exe to install DocProject and the required prerequisites onto your system.
  4. If it fails:
    1. If you're still missing the required prerequisites then run vs90_piaredist.exe.
      1. Note: If you have installed a copy of VS 2005 Standard+ or VS 2008 Standard+ plus then you do not need to install the prerequisites. If you only have VS Express editions installed then you may need the prerequisites.
    2. Try running the .msi file to install DocProject.
I'd appreciate feedback on this issue. Please let me know if you have problems with either the extraction process or running the Setup.exe or .msi programs.

Thanks,
Dave