Can not deploy doc site to another server

Topics: DocSites, General Questions
Aug 28, 2007 at 6:05 PM
I have create Docweb site for my project succeeded on my computer using VS 2005.
Then I try to publish this doc web site and create virtual directory for the results of publushing. It doesn't work.
If I copy the all files (includes source codes,....) to the virtual directory, the doc website will work fine.

Then I try to move this doc website to another machine(windows 2000 with service pack and .NET SDK), it doesn't work.
<httpModules>
<add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
</httpModules>
but all my other .net 2.0 apps with AJAX work well.

What's wrong when I try to deploy this doc website for public to access?
Aug 28, 2007 at 7:18 PM
Hi,

Without seeing error information it's difficult to determine the problem. However, it sounds to me like you might not have deployed the bin directory.

Please note that DocSite Templates produce Web Applications, not Web Sites, which means that you do not have to deploy the source code to the server. Only the ASP.NET files such as .aspx pages, resources such as images and stylesheets, and the assemblies in the bin folder are required.

Here are some articles that may help you to deploy your DocSite project:

Walkthrough: Deploying an ASP.NET Web Application Using XCOPY
http://msdn2.microsoft.com/en-us/library/f735abw9.aspx

Deploying Web Applications [to a third-party host]
http://msdn2.microsoft.com/en-us/smallbusiness/bb545386.aspx

HTH
- Dave
Sep 4, 2007 at 3:23 PM
Thanks for your help, Dave.

I found out the reason.

The reason that doc website has problems when deploying is because the application using AJAX framework and the assembly System.Web.Extensions.dll is not included when deploying.
Sep 4, 2007 at 4:26 PM
Great, thanks for the update. I'll mention this in the DocSite Templates wiki for the next release.

- Dave