Text getting greyed and footer "send feedback" link disabled in chm

Topics: Conceptual Topics, General Discussion, Help 1.x/2.x
Apr 20, 2010 at 1:39 PM
Edited Apr 21, 2010 at 4:21 AM

Hi,

I have been using the docproject to build documentation for my project. Last time I tried some rearrangement of the conceptual contents node (nesting under a root node) and then probably the feedback url link, next I find that the table of contents is coming as desired but all the text in the help file is coming as disabled(greyed out) including the "send feedback" link.

 

Can anybody please point out the cause and probable solution to this problem.

Thanks in advance

Soumik.

Coordinator
Apr 21, 2010 at 3:08 PM
Edited Apr 21, 2010 at 3:11 PM

Hi Soumik,

This sometimes happens when you try to delete the text in the header content item; the one about the documentation being preliminary.  The Topic Designer improperly serializes the empty content item, causing the grayed text to leak out over the document.

I suggest that you open the content file directly and manually fix the XHTML.  You'll find it at, Help\Presentation\Style\Content\shared_content.xml in your DocProject or DocSite.  Search for "header" and ensure that its content is well-formed XHTML.

Just in case, I could also be wrong about which content item in particular is messed up, so if I don't have it correct then browse around this file and the other content files (if necessary) to make sure that everything is well-formed.

Note: In the future when using the Topic Designer, always check the Source tab for a content item before committing any changes.

- Dave

Coordinator
Apr 21, 2010 at 3:17 PM

Hi Soumik,

As for the send feedback link, editing the footer can also mess up the special XML tokens that Sandcastle requires.

In the same content file mentioned in my previous response, search for "footer".  There may be more than one occurrence but only one is not commented out.  The content for the active footer looks something like the following, by default.

<item id="footer">
<span id="feedbackarea">
			Send
		<a>
			<includeAttribute name="href" item="MailToLink">
        <parameter>{2}</parameter>
        <parameter>{3}</parameter>
      </includeAttribute>
      feedback
		</a>
			on this topic to Microsoft.
		</span>
</item>

I suggest overwriting your entire footer item with the content above.  Then you can manually change the text portions if you'd like; e.g., replace "Microsoft" with the name of your company, etc.

Again, this is another one of those content items that you must edit in the Source tab only of the Topic Designer.

- Dave

Coordinator
Apr 21, 2010 at 3:21 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Apr 22, 2010 at 6:31 AM

Thank you Dave. Now I am able to get over the problem.

Thanks for your prompt response. -Soumik

Jan 19, 2011 at 9:56 PM

I went into the footer source and changed "Microsoft" to our company name and now the text is all grayed out in the conceptual topics and the footer. I didn't touch the header and made sure to make the change in the source tab for the footer.