Error starting Add-In VCProjectEngine

Jul 15, 2010 at 4:03 PM

Hi, just installed DocProject which went fine but when I try and start it in VS2008 SP1 I get:

Description:
An error occurred while initializing the DocProject Add-In.

System.IO.FileLoadException: Could not load file or assembly 'Microsoft.VisualStudio.VCProjectEngine, Version=8.0.0.0, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies.
The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

File name: 'Microsoft.VisualStudio.VCProjectEngine, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
   at DaveSexton.DocProject.VCProjectFactory.CreateVCAnyProject(VSProject2 project)
   at DaveSexton.DocProject.ProjectFactory.CreateVSProject(Project project, Boolean canUseCache)
   at DaveSexton.DocProject.ProjectFactory.CreateProject(Object project, Boolean canUseCache)
   at DaveSexton.DocProject.DocProjectEnvironment.<FindProjectsInternal>d__7.MoveNext()
   at DaveSexton.DocProject.MarshalByRefEnumerator`1.MoveNext()
   at DaveSexton.DocProject.BuildController.Refresh()
   at DaveSexton.DocProject.DocProjectAddIn.Extensibility.IDTExtensibility2.OnStartupComplete(Array& custom)

At first I though it might be something to do with having the latest build of SandCastle, but even rolling back to the May 08 build makes no difference.

Anyone got any ideas?

Thanks

Paul

 

 

Jul 15, 2010 at 4:07 PM

Hmm. Restarted VS and all seems well. Should have tried that first of course :-)