Can't build Help 2 with 1.90 RC

Topics: Help 1.x/2.x
Feb 13, 2008 at 6:57 PM
Hi,

I'm using the 1.9 RC of DocProject, and February 2007 VS SDK. The Help 1 building works great, but then I try to build Help 2, it says,

Step 6 of 19: Execute XslTransform
...

XslTransform (v1.0.0.0)
Copyright c Microsoft 2005-2006
Error: The transform file 'E:\Program Files\Visual Studio 2005 SDK\2007.02\VisualStudioIntegration\Tools\Sandcastle\\ProductionTransforms\CreateVSToc.xsl' could not be loaded. The error is: Could not find file 'E:\Program Files\Visual Studio 2005 SDK\2007.02\VisualStudioIntegration\Tools\Sandcastle\ProductionTransforms\CreateVSToc.xsl'.

Is it possible to get the missing file from somewhere, or fix this in some other way?

Thanks for the great tool!

ulu
Coordinator
Feb 13, 2008 at 8:20 PM
Hi ulu,

You have to install the SDK before Sandcastle. Notice that the path being used for Sandcastle points to an older version that ships with the SDK.

The latest version of Sandcastle was probably installed to: C:\Program Files\Sandcastle.

The problem is that the %DXROOT% environment variable, which points to Sandcastle's install directory, was updated to point to the older version when you installed the SDK.

You may want to try to Repair the Sandcastle installation, or just reinstall it.

- Dave
Coordinator
Feb 13, 2008 at 8:23 PM
By the way....

You're probably already aware, but 1.10.0 RC was recently released and it provides features such as improved performance during builds, first-class support for conceptual content and custom dynamic filtering, among other things. If you're just starting a new DocProject or DocSite now then you should probably upgrade.

- Dave
Feb 14, 2008 at 4:55 PM
Thanks a lot, changing the DXROOT variable did it!