German special characters in topics

Topics: Conceptual Topics, Help 1.x/2.x
Apr 15, 2008 at 8:36 AM
Hello,

how can i use the german special characters in the topics. When I use german characters in the documentation then it works perfectly. But when I create a new conceptual document and the header have a german sign (like ä, ü, ....) then this character shown in a Help 1.x incorrectly.

I using Visual Studio 2005 VB.NET, Sandcastel January 2008 and DocProject 1.10.1

Thank you very much
Michael
Apr 15, 2008 at 10:37 AM
Edited Apr 15, 2008 at 10:38 AM
Hi Michael,

Do you mean that when viewing the .chm file, German characters in auto-generated reference topics appear correctly but German characters in conceptual topics do not?

I don't see any reason why one would work but not the other. If you can confirm that this is the behavior you're observing then I'll see if I can reproduce it.

Regardless though, I'm sorry to say that as of now I've only tested DocProject for building English output. However, I do plan to add support for localization in the near future and I've already begun to think about ways to accomplish this. I'll write a blog post soon about my plan.

Currently, 1033 is hard-coded as the value for SandcastleSettings.Lcid, but you may find that providing a value for German instead will fix your particular problem. You can either rebuild the source (How To Use The Source Code) or create a custom provider and override the Lcid property in a custom settings class since it is virtual (Creating a Build Engine Provider). Note that I haven't tested either approach, but I suspect that both will fix your problem.

- Dave
Apr 15, 2008 at 4:14 PM


davedev wrote:
Hi Michael,

Do you mean that when viewing the .chm file, German characters in auto-generated reference topics appear correctly but German characters in conceptual topics do not?



No, I mean in the opend .chm file i have missing charecters on the left side (TreeView) with topics. But in the text of the righht side (the documentations text) there is all right


davedev wrote:
Currently, 1033 is hard-coded as the value for SandcastleSettings.Lcid,


I didn´t find this file. Where can I find it?

- Michael
Apr 15, 2008 at 6:57 PM
Hi Michael,


Currently, 1033 is hard-coded as the value for SandcastleSettings.Lcid

I didn´t find this file. Where can I find it?



Sorry I wasn't clear. Lcid is not a file extension, it's a property on the SandcastleSettings class.

- Dave
Jun 10, 2009 at 5:53 PM

I have the same question when i build the chinese document

Jun 10, 2009 at 7:11 PM

Hi,

You can try setting the LCID value in your project's Help\Settings\Projects\help1x.config file.

Look for <line>Language={2}</line> and replace it with something like, <line>Language=2052</line>.  If you need to use another dialect then you must register the language at the top of the file in the <languages> element.

- Dave