The indexed document 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.xml' is not a valid XML document

Topics: Bugs
Jun 20, 2008 at 9:05 AM
Edited Jun 20, 2008 at 9:05 AM
Hi,

I've just installed the latest Sandcastle and latest DocProject.
When trying to compile any new DocProject's project, i'm getting an error message:

Error    1    The indexed document 'C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.xml' is not a valid XML document. The error message is: '.', hexadecimal value 0x00, is an invalid character. Line 14566, position 128.       


This xml file indeed gets corrupted on that line, but fixing it (there is no opening <see tag) doesn't persist until next compilation.
I'm using VS 2008 TS, .net 3.5 SP1 on Vista x64

Anybody could help?
Jun 21, 2008 at 8:50 AM
Hi,

That's strange since DocProject doesn't write to comments files except those in the project's Help\Comments folder, and only when using the Topic Editor.

Would you mind sending me your DocProject or DocSite?  Send me your email address here and I'll respond back with mine so that you can send the project to me.

- Dave
Jun 23, 2008 at 3:26 PM
Edited Jun 23, 2008 at 4:56 PM
Problem solved.
I could either remove this file or modify it, but without VS intellisense (I needed to manually retype the whole corrupted line rather than rely on intellisense tag completion and formatting).
However, I still don't know which part of sotware corrupted that file.
Jun 23, 2008 at 3:46 PM
I think the problem is related to VS 2008 SP1 Beta.  Can anyone else confirm this?