MAML problem: Cannot link to elements inside a topic

Mar 25, 2009 at 3:51 PM
Hi dave,

i know its not a docproject problem but perhaps you know more:

I do link from  topic file A to another topic file B.

Topic file A:

<link xlink:href="0234jblabla#element"/>

Topic file B:

<section address=element />



Inside of topc file b i can link without problems to section with address "element". But when linking from another topic file to that one it doesnt work. According to the maml guide the syntax used in topic file a is ok and it should work.

Do you have an idea what is wrong here?

Greetings

Marc


Mar 25, 2009 at 7:29 PM
Oh sorry! I have overlooked that this is only possible with an extension component to sandcastle.
Mar 25, 2009 at 8:20 PM
Hi Marc,

Yes, that's what I was thinking :)

If it is a Sandcastle build component that provides this feature and it is distributed stand-alone then you should be able to use it in DocProject as well.  See the following article for more information.

How To Use Third-Party Build Components in DocProject
http://docproject.codeplex.com/Wiki/View.aspx?title=How%20To%20Use%20Third-Party%20Build%20Components%20in%20DocProject

- Dave
Mar 26, 2009 at 11:34 AM
Hi dave,

the component i require is

 ResolveConceptualLinksComponent
or  ResolveConceptualLinksComponent2

unfortunatley these are not available as standalone. I have tried already http://sandextensions.codeplex.com/ but after adding this component as third party in your "Add Build Components" only three new components appear which are:

* MetaAttributeComponent
* KeywordsFilterComponent
* IndexLinkNamespaceComponent

Actually now i would be satisfied when at least the following would work:

<link xlink:href="<topickey>"> Text to display</link>

For this link only the name of the topic is displayed but i want it to display the "Text to display". This would be possible when using the ResolveConceptualLinksComponent .

Do you know a solution to my problem?

thx in advance

greetings

marc

Mar 26, 2009 at 4:17 PM
Edited Mar 26, 2009 at 4:19 PM
I think you want the ResolveConceptualLinksComponent found in the SHFB standalone build components distribution.  It's a reimplementation of the stock component of the same name supplied with Sandcastle.  You can download the standalone components from the the help file builder project site (http://shfb.codeplex.com).

Eric
Mar 26, 2009 at 4:36 PM
Yes i tried this already. I tried to open the SandcastleBuilder.Components.dll in the Add Build Components dialog. Unfortunatley this didn't work. Following error was displayed:

One or more of the selected assemblies could not be inspected due to the following error: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.

Greetings

Marc
Mar 26, 2009 at 5:26 PM
Hi,

Thanks for the response Eric.

Marc, please see the following discussion about the LoaderExceptions issue:

http://docproject.codeplex.com/Thread/View.aspx?ThreadId=30684

- Dave
Mar 27, 2009 at 9:56 AM
hi,

thank you very much. It worked! At first i tried adding the SandcastleBuilder.Component to the references of my project as proposed in the thread. But i encoundered the same error again. Then i added it manually and this worked finally.

greetings

Marc
Mar 27, 2009 at 11:53 AM
Hi Marc,

In that discussion I never suggested that you should add the component to the project's references.  It's referring to the reference (API) build component stacks that are mentioned in the article that I linked to in this discussion.

Regardless, I'm glad that you figured out how to get it working.  Thanks for following up.

- Dave