Error on installation

Topics: Bugs, General Discussion, General Questions
Apr 10, 2007 at 6:56 PM
I recieve the following error:
Could not load file or assembly 'Microsoft.Wizardframework, Version=8.0.0.0, Culture=nuetral ... ...' or one of its dependencies. the located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT:0x80131040).

Help.

Thanks
Sal
Coordinator
Apr 11, 2007 at 12:00 AM
At what point during the installation do you get that error? Is it before, during or after the content installer wizard starts?

Do you have Visual Studio 2005 installed? (Express editions are not supported).
Apr 11, 2007 at 12:42 PM
I recieve the error when it's trying to install the VS 2005 templates/addin.

I have vs 2005 suite, with the database professionals, sp1, .net framework 3.0, and supporting components for 3.0 framework, VS SDK 4.

Thanks
Sal
Coordinator
Apr 12, 2007 at 3:21 AM
Hi Sal,

It sounds like an issue with Visual Studio. I assume that the VS content installer is using the Microsoft.Wizardframework assembly because DocProject does not reference it, at least not explicitly. Try looking at the fusion log to determine what the framework is doing when it tries to load that assembly and what version you have:

  1. Open the VS command prompt
  2. Enter: fuslogvw
  3. The Assembly Binding Log Viewer will open
  4. Open Settings...
  5. Choose Log bind failures to disk
  6. Check Enable custom log path and enter a path (e.g., C:\Windows\Temp)
  7. Click OK
  8. Run the DocProject installer and after it fails click the Refresh button.
  9. Find the Microsoft.Wizardframework binding in the list.
  10. Double-click the item to view the details. And post the data here if you want.
Look for the version number and location of the assembly that the framework tried to load and any error messages. It may be that you have a newer version of that assembly than what the VS content installer expects. If that's the case I don't think there is anything I can do since the content installer is not my code, but let's see if that's true first. Maybe reinstalling Visual Studio will solve your issue; otherwise, we'll have to think of something else ;)

Thanks.
Apr 15, 2007 at 8:14 PM
Hi, I'm getting the same error it sounds like. I'm running Vista (x64) with VS 2005 SP1, and I have a lot of the .NET 3.0 tools installed (include the March CTP of Orcas). It looks like one of these tools updated the Microsoft.WizardFramework.dll to version 9.0.0.0 and your install is bound to version 8.0.0.0.

Here is the binder log entry that you asked for.

      • Assembly Binder Log Entry (4/15/2007 @ 2:00:52 PM) ***

The operation failed.
Bind result: hr = 0x80131040. No description available.

Assembly manager loaded from: C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorwks.dll
Running under executable C:\Program Files (x86)\Common Files\Microsoft Shared\MSEnv\VSContentInstaller.exe
--- A detailed error log follows.

=== Pre-bind state information ===
LOG: User = PEGASUS\blane.nelson
LOG: DisplayName = Microsoft.WizardFramework, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
(Fully-specified)
LOG: Appbase = file:///C:/Program Files (x86)/Common Files/Microsoft Shared/MSEnv/
LOG: Initial PrivatePath = NULL
LOG: Dynamic Base = NULL
LOG: Cache Base = NULL
LOG: AppName = VSContentInstaller.exe
Calling assembly : VSContentInstaller, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a.
===
LOG: This bind starts in default load context.
LOG: No application configuration file found.
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
LOG: Post-policy reference: Microsoft.WizardFramework, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
LOG: GAC Lookup was unsuccessful.
LOG: Attempting download of new URL file:///C:/Program Files (x86)/Common Files/Microsoft Shared/MSEnv/Microsoft.WizardFramework.DLL.
LOG: Assembly download was successful. Attempting setup of file: C:\Program Files (x86)\Common Files\Microsoft Shared\MSEnv\Microsoft.WizardFramework.dll
LOG: Entering run-from-source setup phase.
LOG: Assembly Name is: Microsoft.WizardFramework, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
WRN: Comparing the assembly name resulted in the mismatch: Major Version
ERR: The assembly reference did not match the assembly definition found.
ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated.


Apr 15, 2007 at 11:26 PM
Edited Apr 15, 2007 at 11:26 PM
Hi Again.

If found a workaround for the problem.

The issue is that the system updated the location of the latest wizard framework when I installed one of the .NET 3.0 tools (I'm not sure which one). The 8.0 dlls are still on the system but so are the new 9.0 dlls. For some reason (registry key or config file I think) the install is loading the 9.0 version. To get around this I put the 8.0 dlls in the GAC so .NET could find them. Then the install worked just fine. I then removed the 8.0 dlls from the GAC.

1) Start the .NET 2.0 Confiuration Utility. Start | Control Panel | Administrive Tools | Microsoft .NET Framework 2.0 Configuration

2) In the left hand tree view, open the My Computer item, and right-mouse the Assembly Cache item.

3) Click Add.. menu option

4) Select the BOTH the Microsoft.WizardFramework.dll and Microsoft.WizardFrameworkVS.dll. The are located in the Visual Studio 2005, Common, IDE directory. By default is in C:\Program Files\Microsoft Visual Studio 8\Common7\IDE. On x64 systems it's under the Program Files (x86) directory. Make sure you add both dll's to the GAC.

5) Run the install, it should work now.

6) Now remove the dll's from the GAC. In the Config Utility scroll down until you find the Microsoft.WizardFramework and right-mouse click on it. Click the Delete menu item. This will NOT "Delete" the orgianl dlls on the disk, just remove the item from the GAC. Repeat for the Microsoft.WizardFrameworkVS dll as well.

Coordinator
Apr 17, 2007 at 10:39 AM
Hi lexnn,

Thank you very much for posting this work-around.

According to your log it's Microsoft's VSContentInstaller.exe program that is bound to the 8.0 assembly, which cannot be found since a 9.0 version has taken its place. This program is installed by Visual Studio so I suspect that the CTP of Orcas is the problem here. Also, I've developed, tested and built the deployment package for DocProject on a .NET 3.0 system (Windows Vista) but I've only installed Orcas on a Virtual Machine. I assume that Orcas is updating the required assembly to 9.0 since that's the latest version of VS.

I'm really beginning to think that the VS content installer is a waste of time and causes more problems then it's worth for DocProject. I'll consider whether the DocProject installer should copy the necessary files itself for a subsequent release; otherwise, I'll note that the DocProject installer is not compatible with the Orcas CTP in the release notes.

If anyone would like to comment about whether DocProject should continue to use the VS conent installer I'd appreciate it.

Thanks again.
Apr 18, 2007 at 3:58 PM
Sorry, i was away for a business trip. If you would like i will still post the my binder log. But in the mean time i will try the work-around.

Sal
Apr 18, 2007 at 4:06 PM
Hi Davedev and Lexnn,

The work around helped. it allowed me to install the vs-addins. Thanks for the help.

Sal
Coordinator
Apr 18, 2007 at 5:23 PM
Hi Sal,

I'm glad that you were able to work-around the issue using lexnn's suggestion.

By any chance do you have an Orcas CTP installed? I'd like to know so that I can warn others of this problem in the release notes for the next release of DocProject (unless I exclude the VS content installer, which I just might do).

- Dave
Apr 18, 2007 at 7:55 PM
I did at one point but it has been uninstalled. To many issues. I still have the 3.o framework installed.

Sal
Coordinator
Apr 18, 2007 at 9:21 PM
Hi Sal,

I'm fairly certain that the Orcas CTP is the issue. Uninstalling it probably didn't replace the 9.0 version of the assembly with the older, 8.0 version. I built DocProject on the 3.0 framework, so I highly doubt that has anything to do with it.

Thanks.
Coordinator
Apr 30, 2007 at 8:50 PM
Hi,

The DocProject 1.5.0 installer (just published) no longer uses the Visual Studio Content Installer. I tested the latest installer on Windows Server 2003 with the Orcas March 2007 CTP installed and it worked fine.

If you try it, please let me know if you have any problems. Thanks.